Fantasy Letter by Erik Brimstedt

Okay, we'll do a tutorial on heavy texturing now, turning a simple flat plane with a bunch
of polygons into an old piece of paper with handwriting on it. 50% of the work will be
done in Photoshop, and there’s where we'll start. In the end, you’ll hopefully have
something looking like the following picture.

Picture 1: The finished image

Lets get going! Start by loading up Photoshop. I'm using version 5.5 but I'm sure this can
be done in both earlier and later versions. Set the background colour to white, and the
foreground colour to black, and then create a new document - 21cm wide and 29cm
high. Select the Airbrush tool, and then change the pressure to 100%. I am using the
smallest of the sharp square brushes, look at picture 2 to check my settings.
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Picture 2: The settings for the airbrush tool




Okay, what we’ll do now is draw a line how we want the edges of our Fantasy letter to
look. Put some time in this to get a good result, picture 3 is my creation. Start drawing
about 1cm in on the image, and not at the very edges.
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Picture 3: Draw an outline using the airbrush tool




Save this outline as outline.jpg somewhere on your hard drive now, if something should
go wrong we are safe. Finished with that part? Good, select the Paint bucket tool, and set
the pressure to 100%. Now click somewhere on the outer side of this line to fill it with
black, looking something like picture 4. Note, the following picture is smaller than the
actual image; it’s just to show you what part should be filled with black.
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Picture 4: Fill the outer area with black

The first map we will create for Lightwave is the Clip Map, but before we need to make
sure that the edges are really sharp, and we can fix this by adjusting the Levels. Use the

Magnify tool and zoom in a corner of your paper, looking something like picture 5. I
zoomed in the lower left corner.
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Picture 5: A zoom_e-d-:in corner; note the AntiAliasing that we need to get rid of.



Okay, select “Image -> Adjust -> Levels” and a panel should appear. Use the
following settings.
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Picture 6: Adjust the Levels with the settings in the window.
Note how the AntiAliasing disappears.

Click OK when you’ve entered the values shown, and the AntiAliasing is gone, now you

can zoom out again to regular size. This is it for our Clip Map. Select "Save As” in the
File menu and set the filename to “Paper_Clip.jpg”.



Okay, lets get on with creating a transparency map. In the History Panel, the latest
action should be the “Levels” one, as in picture 7.
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Picture 7: History Panel

We need to undo the last action here, so click on the “Paint Bucket” action in the history
panel; this will remove the “Levels” action. Okay, we will apply a filter to the edges of
this paper now to use as transparency later on, so select

“Filter -> Sketch -> Water Paper”. Set the Fiber Length to 4, the Brightness to 70 and
the Contrast to 77, then click OK.

The edges of our paper will now be “fiberized”. Save this image as “"Paper_Transp.jpg”.

Okay, now we need a Displacement Map. Undo the Fiber action in the History Panel and
get back to the last Paint Bucket action (like before when we undo’ed the Adjust Levels
action).

Select the Magic Wand tool, set the Tolerance to 30 in the Magic Wand Options panel and
then click somewhere on the outer black area. This will make a selection that follows the
outer line perfectly. In the menu, choose “Select -> Inverse”, which will inverse the
selection so we are working with the white area.



Select "File -> Preferences -> Guides & Grid” and set the Gridline to every 50 pixels.
Also set the subdivisions to 1, then click OK. Turn on the Grid from the “View” menu, but
turn off Snap to Grid. What you have now should look something like picture 8.
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Picture 8: Grid is oh, Snap to Grid is off, and the Magic Wand tool has been used.



Select the Airbrush tool and set the pressure to 5%. Select a 35 sized soft round brush
from the brushes panel and then paint the edges here and there to add some darker
areas. Then pick out a vertical grid line that is closest to the middle of the paper, and
paint along that grid line. Then use 2 horizontal grid lines and paint along those. Look at
picture 9 and you’'ll know what I mean.
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Picture 9: Use the Airbrush to darken the edges, and also the
middle vertical grid, and two horizontal grids.

You can change sizes of brushes as you like, but try to get as similar to picture 9 as
possible. Also use a big brush, 100-200, and paint all over the image to get rid of all the
white.

When you are done, save this as “"Paper_Disp.jpg”.



Now use the Magic Wand tool again to select the outer black area, and then inverse the

selection. Change the Background colour to R: 215 G: 182 B: 131, and the Foreground
colour to R: 236 G: 202 B: 142.

Use the “Edit -> Fill” tool and then fill this selection with 100% background colour.
Select “Filters -> Texture -> Texturizer” and use the following settings.
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Picture 10: The Texturizer settings

Click OK and the texture should apply within the selection borders.



Create a New Layer with 100% Opacity and the Mode to Color Burn. Select the Airbrush
tool and set the pressure to 10%, and also select a soft round brush with 100 in size.
Then paint here and there within the selected area so it looks something like picture 11.
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Picture 11: Airbrush here and there.
NOTE: the round ring is just my airbrush tool ;)



Do you remember how we painted along a couple of grid lines earlier when we created
the displacement map? Well, the displacement map will make those darker areas appear
bumpy in the final image, so in this colour image, we will create what will look like worn
edges along those grid lines, know what I mean?

I can’t explain every paint procedure I do, so I will leave this up to you. You can create
as many new layers as you want with the Color Burn mode, and then paint edges and
along grid lines to make it look old and worn. For Darker Red and brown areas, simply
change the Foreground colour to what colour you want to “burn” the image with. Look at
picture 12, this is my final colour image; try to create the same effects with your brush
tools.
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Picture 12: The finished colour Image



When you have finished the work on your colour image, Flatten it and save it as
“Paper_Col.jpg”. Note that I burned along those Grid Lines that we also used during the
creation of the displacement map.

Only one map left to create! The Text. You can use what you want for this, if you want to
create a treasure map, or a letter like me, it’s up to you. Create a new project with the
same sizes as before (Width: 21cm Height: 29cm). Use a White Background and a Black
Foreground colour, then select the Type Tool and start writing your text with a good
looking font! You might want to keep the text in the middle of the image, since we will be
using clip maps and such later on. Picture 13 is what mine looked like.
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Picture 13: The Text we will map on our Letter

Note that I also used the Smudge tool to smear out the text after I created it, making it
look a bit older. Save this as "Paper_Text.jpg” when you are finished.



Okidoki, all texture maps have been created, so lets use them in Lightwave! You can
close down Photoshop now if you want to, and then load up Lightwave Modeler. Create a
box with the following settings.
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Picture 14: The Box settings
Create a surface for this object called “"Paper” and turn smoothing on, then save this

object as “Paper.lwo”. That's it for modeler, at least for now, so load up Layout and load
the Paper object in. Place and Rotate the Camera to the following.

Picture 15: Camera Position

Picture 16: Camera Direction



Open up the Lights Panel and set the only light in the scene to the following.
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Picture 17: The Light properties
Next, use the following position, direction and scaling for the light.
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Picture 18: The Light Position

Light Direction

Picture 19: The Light Direction

Light Scale

Picture 20: The Lights Scaling



If you render a preview now by hitting F9 it should look something like picture 21.
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Picture 21: The first test render
Enter the Images Panel and load in all the images we made in Photoshop, it’s time for
some texturing. We are going to start with the Displacement Map, so open up the
Objects Panel and click the T for Displacement Map, use the following settings.
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Picture 22: The Displacement Map
Remember to click Automatic Sizing for this one!



Click OK and render another test render, it should look something like picture 23.
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Picture 23: The Displaced paper
Okay, open up the Objects Panel again and click the T for Clip Map, now we are going to
cut of the edges of this paper. Use the following settings, and remember Automatic
Sizing.

Clip Map 1 for “Paper_lwo™

Picture 24: The Clip Map



The Test render would look something like picture 25 at this point.

i Render Dizplay - Frame 0 [1:1]

Picture 25: The Clip map added

Now let’s make this look more like paper, so open up the surfaces panel. We will start out
with the transparency map to soften the edges and give them a fibre like look, so use the
following settings in the Transparency Texture Channel.
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Picture 26: The Transparency Channel Texture
Don't forget Automatic sizing 8)



Click OK when you’re done with the transparency texture and then click the T for the
Color channel. Use the following texture settings.
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Picture 27: The Texture for the Color channel

Once again click automatic sizing. When you’re done with that one, click Add New
Texture to add another layer, and then use the following settings.
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Picture 28: A Fractal Noise texture for the Color channel



Click OK when you’re done with the Color Channel, then render a test render, it should
look something like picture 29.
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Picture 29: Color added

Okay, getting somewhere eh? Get in the Surfaces Panel again and enter the Texture
Channel for Diffuse. Use the following settings.

Diffuse Texture 1 for "Paper™

Picture 30: The Diffuse Channel Texture
Don’t forget automatic sizing 8)



Click Add New Texture when you are done with the first, and use the following settings
for this one.

fluse Texture 2 for "Paper™

Picture 31: The Fractal Noise in the Diffuse Channel

If you render a preview now, it should look something like picture 32.
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Picture 32: Another test render with diffuse layers added



Okay, we are just going to add a few procedurals in the Bump Map channel now to get
the final paper look, and then it’s time for some bones. Open up the Bump Map Channel
and use the following settings for the first texture.
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Picture 33: The first Crumple Texture
Add another Layer and use the following settings.
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Picture 34: Second Crumple layer in the Bump Channel



Okay, just one more layer and the paper texture is finished. Add a new layer and use the
following settings.
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Picture 35: The Third layer in the Bump Map Channel

If you hit F9 to do a test render now it should look something like this.
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Picture 36: The finished paper texture



Okay, we are soon finished, but lets add some more geometry to the paper by using a
few bones. Switch to Top View and fit the paper in the view.

Click the Bones button to the left of layout, and then choose “"Add -> Draw Bones”.
Then Draw 4 bones, one in each corner with an angle of about 45 degrees. Look at
picture 37 and you’ll know what I mean.

Picture 37: Add 4 bones, one in each corner using Draw Bones

Now select "Bone (1)” in the “"Selected Item” list at the bottom of Layout and hit “r”
on your keyboard to rest this bone, then select Bone 2, 3 and 4 and do the same. Before
we start deforming the paper, we need to set a maximum range for these bones, so open
up the Objects Panel and click "Object Skeleton” and a new panel should appear.



Select "Bone (1)” in the list and click the “Limited Range” button, Keep the Minimum
range at 0 and set the Maximum range to 3cm. Do the same with the other three bones,
but you can vary the range between 3cm and 5cm. When you're done, click close panel.
Now it's up to you how you want to deform the edges of the paper. I simply chose a bone
and rotated it using the Right Mouse button (Bank); doing so will curl the edges a bit. I
also added two bones in the middle of the paper and curled it a bit there to, and my final
scene looks like this.

Picture 38: Bones added (Camera View)



Picture 39: Top View of the paper



Now, if you render a test from this it should look something like picture 40.
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Picture 40: The final paper with bones added

Okay, go to the objects panel and click Save All Objects, then save the scene somewhere
to keep the Bones and stuff attached to the paper. All you have to do now is render this
in perhaps a higher resolution and with AntiAliasing. Perhaps go into modeler and model
a table like I did? It’s up to you, I hope you learned something from the tutorial and I
wish to thank you for reading it!
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